Upgrade to version 5.10 fails due to missing service file

I’m having an issue trying to update from version 5.7 to 5.10. I’m following the update instructions from here:


As the metasfresh user the sql_remote.sh script ran with no problems but when I tried running the minor_remote.sh script it ended with this:

The systemd service file /etc/systemd/system/metasfresh-admin.service is not yet installed.
To perform this task and possible others, please run the following shell script as SUPER USER. Then rerun this script.

/home/metasfresh/metasfreshupdate_5_10/dist/install/prepare_services_superuser.sh -s /home/metasfresh /local_settings.properties -d /home/metasfresh/metasfreshupdate_5_10/dist

I ran the command above as root and it failed with:

Checking if /etc/systemd/system/metasfresh-material-dispo.service exists
!!! Installing service unit file !!!
unzip: cannot find or open /home/metasfresh/metasfreshupdate_5_10/dist/deploy/services/metasfresh-material-dispo-configs.zip, /home/metasfresh/metasfreshupdate_5_10/dist/deploy/services/metasfresh-material-dispo-configs.zip.zip or /home/metasfresh/metasfreshupdate_5_10/dist/deploy/services/metasfresh-material-dispo-configs.zip.ZIP.

Also now I cannot su to the metasfresh user:

root@metasdemo:~# sudo su metasfresh
su: Cannot fork user shell
Cannot execute /bin/bash: Resource temporarily unavailable

Hello @greg

I ran the command above as root and it failed with:

I’m taking a quick look now

Also now I cannot su to the metasfresh user:

i guess you are trying to su back to metasfresh after you already su’ed from metasfresh. If that’s the case, simply try exit when you are root and want to be metasfresh again :slight_smile:

it turned out that we introduced a bug in the update procedure of release 5.10.
As a workaround, can you please to the following as user metasfresh?

cd /home/metasfresh/metasfreshupdate_5_10/dist/deploy/services
mv metasfresh-material-dispo-service-configs.zip metasfresh-material-dispo-configs.zip 
mv metasfresh-material-dispo-service.jar metasfresh-material-dispo.jar

After that, running

/home/metasfresh/metasfreshupdate_5_10/dist/install/prepare_services_superuser.sh -s /home/metasfresh/local_settings.properties -d /home/metasfresh/metasfreshupdate_5_10/dist

as superuser should succeed.

Sorry for the inconvenince, but thanks for bringing up the problem!

I had to reboot the server to successfully run the command above as it could not stop the metasfresh-webui-api process. Also needed to reboot to su to the metasfresh user. I was then able to re-run the minor_report.sh script as the metasfresh user. There is a space in the -s option above that should not be there.

Thank you, I edited my post and fixed it

FYI, I created this issue

https://github.com/metasfresh/metasfresh/issues/1640 (edit: just added the URL too :blush: )