Problems running after install on both Docker and Deb


I am having problems running metasfresh after install using both Docker and Server (Deb) methods.

Following all the install instructions to the exact letter and then attempting to open via ip address in a broswer results in a blank html page (but with a metasfresh browser icon showing)

I have tried for hours on different vm servers, but always the same result and always following the install instructions on a brand new vm or vps.

Thanks in anticipation, I really wanted to test metasfresh as I cannot find a demo anywhere.


  1. Docker Server: Ubuntu Docker 17.06.0-ce on 16.04 + Latest version of metasfresh (from git)
  2. Normal Server: Ubuntu 16.04 + Latest version of metasfresh

Hi Mark,

that sounds like your browser can not connect to the RESTAPI.
Did you edit the config.js before building the webui image?
You can verify the URLs by opening the dev mode (CTRL+Shift+I in chrome), opening console and pressing refresh.
You will see a config.js in the list. Click on it and verify the URL is what you want.

please let us know how it goes and if you need further assistance.

Kind regards,

1 Like