Metafresh on Microsoft Azure on Ubuntu 16.04 WebUI not working


#1

Hi,

I have done Metafresh setup on Microsoft Azure on Ubuntu 16.04.
I can access link with 8080 port but my WebUI gives me a blank screen.

I have followed this link for installation-:
http://docs.metasfresh.org/installation_collection/EN/installer_how_do_install_metasfresh_package.html


#2

Hi @pushkar_sawant

most likely, the url of the config.js for the webui is not configured correctly.
On the metasfresh installer, you should be able to find the config file here:
/opt/metasfresh-webui-frontend/dist/config.js

Make sure the URLs in the file’s content reflect your publicly accessible URL. In case you configured a DNS correctly the should look like this:

const config =  {
    API_URL: 'http://myserver.com/rest/api',
    WS_URL: 'http://myserver.com/stomp'
}

This can also be found here: http://docs.metasfresh.org/installation_collection/EN/installer_how_to_change_hostnames_for_webui.html

Can you also make sure that you have access to your server on port 80/TCP as well?
You can also check if the webui-api service is active (running):
sudo systemctl status metasfresh-webui-api.service

Cheers,
Julian


#3

Hi Julian,

Thanks for the reply on my query.

I checked and yes the webui service is running. also the server port 80 is accessible.
also I updated config.js file in /opt/metasfresh-webui-frontend/dist/ as per my hostname.

It is like -:
http://metasfresh.cloudapp.net:8080/ (This is opening) But if you check http://metasfresh.cloudapp.net/ its still showing blank page. !!

Thanks
Pushkar


#4

Hi Pushkar,

you will need to change the config.js without the :8080.
The URL http://metasfresh.cloudapp.net:8080/ should just be for the welcome page where you can also download the client.

in your case, the contents of config.js should look like this exactly:

const config =  {
    API_URL: 'http://metasfresh.cloudapp.net/rest/api',
    WS_URL: 'http://metasfresh.cloudapp.net/stomp'
}

(note, I ommitted the 8080)


#5

Yes, I did exactly the way you mentioned. but sum how its not working for me.
Now I am setting up Metasfresh on Azure cloud lets see what come out.


#6

Hi,
No luck I tried the installation once again and facing the same problem.
I did all the things which we have discussed earlier.

Link - : http://metasfresh.cloudapp.net:8080/ (This is opening)

Link -: http://metasfresh.cloudapp.net/ (This is not opening)


#7

Hi,

Can you check if you get an error message if you open the developer tools of your browser and hit refresh on webui?

Hint:
Chrome: CTRL+SHIFT+j
Firefox: CTRL+SHIFT+k


#8

Yes, Its attached. -:

I don’t have idea where this ip came from.


#9

That’s usually set in the config.js file.

Can you switch to the tab Sources in the developer tools, hit refresh again and post the image when selecting the config.js?


#10

This my config.js -:
const config = {
API_URL: ‘http://metasfresh.cloudapp.net/rest/api’,
WS_URL: ‘http://metasfresh.cloudapp.net/stomp
}


#11

Hi,
I’m talking about the actual config.js your browser uses:

Can you send me a screenshot of this?


#12

Hi Julian,

Its seems it works on Edge browser and not in Chrome Could not found the reason.

But I can login to metasfresh from edge browser & form incognito from chrome.

May it was problem with my chrome browser cache.

By the way Thanks a lot for your support.


#13

Ah, yes, that explains a lot.
For refreshing the cache of chrome, you might want to check this out: https://superuser.com/questions/220179/how-can-i-do-a-cache-refresh-in-google-chrome

Great that solved it :slight_smile: