Links to REST api scripts are over http not https


#1

I am using nginx-proxy to handle the ssl to metasfresh. I have set “WEBAPI_URL” in docker-compose.yml to “WEBAPI_URL=https://my.domina.co.za”. On the login page all the links to the rest api are over http and consequently blocked by the browser. This behaviour can be disabled in the browser but it would be better to fix the links if the WEBAPI_URL is set to https.

regards


#2

hi

you can setup the API to use SSL and then you can use https on the client.
Here is a howto: http://docs.metasfresh.org/installation_collection/EN/How_do_I_setup_metasfresh_docker_with_ssl.html

cheers,
norbert