Installation stuck when install metasfresh on Ubuntu Subsytem Linux for Windows

english

#1

Hi all,

i’m newbie in metasfresh and try to install it on Ubuntu Subsytem Linux on Windows 10. The Installation process have a stuck in the code below:


Creating config file /etc/postgresql-common/createcluster.conf with new version

Creating config file /etc/logrotate.d/postgresql-common with new version
Building PostgreSQL dictionaries from installed myspell/hunspell packages…
Removing obsolete dictionary files:
invoke-rc.d: could not determine current runlevel
libpq5:amd64 (9.5.13-0ubuntu0.16.04) wird eingerichtet …
postgresql-client-9.5 (9.5.13-0ubuntu0.16.04) wird eingerichtet …
update-alternatives: /usr/share/postgresql/9.5/man/man1/psql.1.gz wird verwendet, um /usr/share/man/man1/psql.1.gz (psql.1.gz) im automatischen Modus bereitzustellen
postgresql-9.5 (9.5.13-0ubuntu0.16.04) wird eingerichtet …
Creating new cluster 9.5/main …
config /etc/postgresql/9.5/main
data /var/lib/postgresql/9.5/main
locale C
socket /var/run/postgresql
port 5432
update-alternatives: using /usr/share/postgresql/9.5/man/man1/postmaster.1.gz to provide /usr/share/man/man1/postmaster.1.gz (postmaster.1.gz) in auto mode
invoke-rc.d: could not determine current runlevel
libxslt1.1:amd64 (1.1.28-2.1ubuntu0.1) wird eingerichtet …
postgresql-contrib-9.5 (9.5.13-0ubuntu0.16.04) wird eingerichtet …
postgresql-contrib (9.5+173ubuntu0.2) wird eingerichtet …
libapr1:amd64 (1.5.2-3) wird eingerichtet …
libaprutil1:amd64 (1.5.4-1build1) wird eingerichtet …
libaprutil1-dbd-sqlite3:amd64 (1.5.4-1build1) wird eingerichtet …
libaprutil1-ldap:amd64 (1.5.4-1build1) wird eingerichtet …
liblua5.1-0:amd64 (5.1.5-8ubuntu1) wird eingerichtet …
apache2-bin (2.4.18-2ubuntu3.9) wird eingerichtet …
apache2-utils (2.4.18-2ubuntu3.9) wird eingerichtet …
apache2-data (2.4.18-2ubuntu3.9) wird eingerichtet …
apache2 (2.4.18-2ubuntu3.9) wird eingerichtet …
Enabling module mpm_event.
Enabling module authz_core.
Enabling module authz_host.
Enabling module authn_core.
Enabling module auth_basic.
Enabling module access_compat.
Enabling module authn_file.
Enabling module authz_user.
Enabling module alias.
Enabling module dir.
Enabling module autoindex.
Enabling module env.
Enabling module mime.
Enabling module negotiation.
Enabling module setenvif.
Enabling module filter.
Enabling module deflate.
Enabling module status.
Enabling conf charset.
Enabling conf localized-error-pages.
Enabling conf other-vhosts-access-log.
Enabling conf security.
Enabling conf serve-cgi-bin.
Enabling site 000-default.
invoke-rc.d: could not determine current runlevel
metasfresh (5.68) wird eingerichtet …
[INFO] Adding User metasfresh
[INFO] Generating initial configs
[INFO] Integrating configs
[INFO] Putting application in place

anyone can help me please…

thanks in advance

BIP


#2

Hi @BangIpool

the Linux Subsystem for Windows 10 is originally just designed to run elf executables and some basic shell scripts. It is afaik not designed to run complex applications like an ERP-Server. So the issue of it hanging when installing could be on various different levels: starting from not having correct permissions for some folders to for the installation required files not being available on the Subsystem at all.

I would highly recommend NOT trying to install metasfresh on the Windows 10 integrated Linux Subsystem - Ubuntu branding or not.

There are, however alternatives if you want to try metasfresh:
1.
If you’re just interested in testing metasfresh and checking out our webinterface, you can subscribe on our website here: https://metasfresh.com/en/nextgen/ and get a personal demo instance free of charge.
‘Demo’ in the sense of that it will be removed if you don’t opt in after a week. All functionality of the full metasfresh service is included in that free of charge demo-instance.
Plus, you don’t have to bother to install it. We’re doing that for you.

If you want to install metasfresh on premise in your environment or are just interested in how to install metasfresh, I would suggest using a virtual machine for that.
We’ve had pretty good experiences with running a Virtualbox Ubuntu on a powerful enough Desktop PC (at least 8GB RAM - depending on what Windows applications you’re running in the background).
Here are some links for the resources required:
Virtualbox: https://www.virtualbox.org/
Ubuntu 16.04 Server amd64: http://releases.ubuntu.com/16.04/
With that up and running you should be able to follow our guide to have a metasfresh installation running on premise: http://docs.metasfresh.org/installation_collection/EN/installer_how_do_install_metasfresh_package.html

Go the docker-route:
You can also install docker and docker-compose on your Desktop PC and install metasfresh using our docker-repository from github: https://github.com/metasfresh/metasfresh-docker
However, please keep in mind we only tested the docker installation on linux server. So I’d suggest installing a VM (eg. Virtualbox) and install docker and metasfresh-docker on there. Here’s a guide on how to install metasfresh-docker using the example of a Ubuntu Server: http://docs.metasfresh.org/installation_collection/EN/How_do_I_setup_the_metasfresh_stack_using_Docker.html

Of course, maybe someone else from our community tried installing metasfresh on the Linux Subsystem for Windows and succeeded, but I don’t think I’ve heard of someone succeeding ( if anyone actually did it, please correct me and maybe put a short how to in here ).


#3

Hi Julian,
thanks for your details explanation. i have successfully installed python-based BI server on Linux Subsystem for Windows 10 (WSL), so i assumed that the erp-server like metasfresh can also be installed there (WSL).

As your mention above that “So the issue of it hanging when installing could be on various different levels”, i just read from another forum about WSL, it turns out that WSL i use (Ubuntu version 16.04) does not support init/runlevel. The init/runlevel issue was resolved with the WSL ubuntu version 18.04, while metasfresh only supports ubuntu until version 16.04.

Will the metasfresh server be installed on ubuntu 18.04? what version?

I have tried the demo version for 7 days, and currently there is an offer for 1 free user account from Norbert. I interested to install it in my environment, so I will try to install it on virtualbox as you suggested in point 2.

Thanks for your advice.

bangipool