I ran docker-compose up and shows blank page on http://localhost:8080/

Hi All,
I am new to metasfresh and I select to go with the docker option on Windows 10. I ran the docker-compose up and it seems up the WebUI on port 8080 but seems error in DB.
Could you please advise me on this.

Regards
Senaka

Creating metasfresh-docker_db_1 … done
Creating metasfresh-docker_rabbitmq_1 … done
Creating metasfresh-docker_search_1 … done
Creating metasfresh-docker_app_1 … done
Creating metasfresh-docker_webapi_1 … done
Creating metasfresh-docker_webui_1 … done
Attaching to metasfresh-docker_search_1, metasfresh-docker_db_1, metasfresh-docker_rabbitmq_1, metasfresh-docker_app_1, metasfresh-docker_webapi_1, metasfresh-docker_webui_1
app_1 | standard_init_linux.go:211: exec user process caused “no such file or directory”
db_1 |
db_1 | PostgreSQL Database directory appears to contain a database; Skipping initialization
db_1 |
db_1 | FATAL: data directory “/var/lib/postgresql/data” has wrong ownership
db_1 | HINT: The server must be started by the user that owns the data directory.
rabbitmq_1 | 2020-09-09 14:57:49.686 [info] <0.33.0> Application lager started on node rabbit@90552404bf91
search_1 | [2020-09-09 14:57:25,733][WARN ][bootstrap ] unable to install syscall filter: seccomp unavailable: your kernel is buggy and you should upgrade
search_1 | [2020-09-09 14:57:27,360][INFO ][node ] [Solara] version[2.4.6], pid[1], build[5376dca/2017-07-18T12:17:44Z]
search_1 | [2020-09-09 14:57:27,360][INFO ][node ] [Solara] initializing …
search_1 | [2020-09-09 14:57:30,657][INFO ][plugins ] [Solara] modules [reindex, lang-expression, lang-groovy], plugins [], sites []
webapi_1 | standard_init_linux.go:211: exec user process caused “no such file or directory”
search_1 | [2020-09-09 14:57:31,040][INFO ][env ] [Solara] using [1] data paths, mounts [[/usr/share/elasticsearch/data (grpcfuse)]], net usable_space [133.6gb], net total_space [221.6gb], spins? [possibly], types [fuse.grpcfuse]
search_1 | [2020-09-09 14:57:31,041][INFO ][env ] [Solara] heap size [247.5mb], compressed ordinary object pointers [true]
search_1 | [2020-09-09 14:57:43,922][INFO ][node ] [Solara] initialized

I tried with a fresh approach. Just mapping default port for wbeui. (port 80 . I mean HTTP://localhost), Still I only get a blank page. In the docker dashboard shows db and webapi containers starting not running.
Could please advise me.

Hi @senaka

Generally, we recommend running the metasfresh server docker installation on a Linux Server ( Ubuntu Server works pretty well ).

The permission error in Windows for the postgres database container looks like a very common issue:



If you really want to run the server in Windows 10 Linux Subsystem, I suggest checking out the issues (and solutions) in the links above.

Alternatively you could just create a Virtualbox machine on your Windows environment with a Ubuntu Server 20.04 installation and try to deploy metasfresh that way (please note the hardware requirements here when setting up the virtual machine: https://docs.metasfresh.org/installation_collection/EN/How_do_I_setup_the_metasfresh_stack_using_Docker.html )

Anyway, please let us know which approach you chose and if you try the Windows 10 docker installation and managed to solve it, consider sharing your solution here so others may find your answer.

Hi Julian,
Thank you for your reply. I will first try out on Ubuntu.
If I succeed in Windows 10, definitely share here.

Regards
Senaka