Forgot Password does not work

Hi there,

I tried using the “Forgot password” function, but it always throws this error:

Mail System not configured. Please define some AD_MailConfig or set AD_Client.SMTPHost; AD_MailConfig search parameters: AD_Client_ID=ClientEMailConfig(clientId=ClientId(repoId=1000000), sendEmailsFromServer=false, smtpHost=, smtpPort=25, startTLS=false, email=null, smtpAuthorization=false, username=, passwordResetMailTemplateId=Optional[MailTemplateId(repoId=50000)]

I am on 5.162.2-267+release on docker using ubuntu 18.04.
SMTP settings are entered for system user (via java client) and all other users via web ui (but they do not reflect these settings) and sending test mails from the web ui does work.

Can you hint me where to enter the default mailserver for the “Forgot Password” function?

Thanks,
Timo

hi timo,

the problem is a missing mail server config.

Try setting one up as described here: https://docs.metasfresh.org/webui_collection/EN/Outbound_documents_setup_email_server.html

Then create a routing as described here:
https://docs.metasfresh.org/webui_collection/EN/Setup_email_server_routing

BUT: instead of configuring the routing for a document or Process you select “Custom Type”:

Might be that you need a server cache reset to make it effective.

Let me know if that worked for you!

Norbert

1 Like

Wow, thanks for the quick reply. It worked.
A follow up question:
The resulting reset link comes with localhost and the wrong port, even though metasfresh runs (and should know) its public DNS entry.
http://localhost:3000/resetPassword?token=XY

Do I have to tell metasfresh somewhere else on which domain/port it is running?

Thanks alot,
Timo