Docker app not able to connect to db


#1

Hi.
I downloaded in Kinematic the four Metasfresh dockers. I am able to connect to the database using, for example, ODBC but the docker app (metasfresh-app) keeps saying “db: forward host lookup failed: No address associated with name”.
Please help.


#2

hi Leandro,

thanks for your post.

I am sorry but I do not have experience with Kinematic but I do know for sure that it works on docker compose.
Do you have the chance to install it on docker compose ?

My stack is:
ubuntu 16.04 LTS
docker & docker compose just like described here:
http://docs.metasfresh.org/howto_collection/EN/How_do_I_setup_the_metasfresh_stack_using_Docker.html

cheers,
Norbert


#3

Thanks.
I left Kitematic and tried the way described in your link.
I made everything and at the very end I obtained the message “Successfully built” but when I try http://172.17.0.1:80 in Firefox I receive a “page not found” message.
In config.js I set 172.17.0.1 as MYDOCKERHOST and 80 as PORT. 172.17.0.1 is the IP address of my Ubuntu VM in the “docker0” network interface.


#4

hi Leandro,

Might port 80 used by another application on your server?

regards,
Norbert


#5

Also I am not sure if it is a good thing to use an IP Address instead of a DNS Name as the apache is setup for reacting to a hostname.

@julian.bischof can you clarify, please?

cheers,
Norbert


#6

Hi

No, it shouldn’t be an issue if you’re using an IP in the config.js since the proxy config does not filter for a specific hostname.
Sound to me, like the containers didn’t start properly or a connection issue from the VM to the client (due to firewall settings maybe).

@leandrof
You can check if the containers are running properly by running sudo docker ps.
In the list, all necessary containers should be listed as well as their startup time. If one or more of the four containers is not having the same startup time as the others, you can identify which container tries to restart/fails.

Also, as Norbert said, if there’s already a service running on port 80 ( check netstat -tunap ) you might want to either stop that service or configure your docker-compose.yml file to use a different port.
In this case, change:

...
  ports:
    - "80:80"
...

to

...
  ports:
    - "8585:80"
...

(don’t forget to update your config.js from port “80” to “8585”, restarting the containers with docker-compose up -d and using that port in the browser address bar “http://myserver:8585”)

Greetings,
Julian


#7

I used “sudo docker ps” and I saw no metasfresh containers running. I type “docker-compose up -d” and they started and now I am able to login.
Sorry for having to ask you so basic info but I am a beginner with docker.
Thank you very much.


#8

Glad to be of help :slight_smile:

And don’t hesitate to ask, if you have any questions.

Enjoy,
Julian