Metasfresh/de.metas.reactor build errors


#1

Hi,

While building metasfresh/de.metas.reactor repository build of de.metas.adempiere.adempiere.base failed with the following error messages:

[ERROR] Failed to execute goal on project de.metas.adempiere.adempiere.base: Could not resolve dependencies for project de.metas.adempiere.adempiere:de.metas.adempiere.adempiere.base:jar:10.0.0: The following artifacts could not be resolved: javax.jms:jms:jar:1.1, com.lowagie:itext:jar:2.1.7.js5, org.jpedal:jpedal:jar:1.0: Could not find artifact javax.jms:jms:jar:1.1 in central (https://repo.maven.apache.org/maven2), try downloading from http://java.sun.com/products/jms/docs.html -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project de.metas.adempiere.adempiere.base: Could not resolve dependencies for project de.metas.adempiere.adempiere:de.metas.adempiere.adempiere.base:jar:10.0.0: The following artifacts could not be resolved: javax.jms:jms:jar:1.1, com.lowagie:itext:jar:2.1.7.js5, org.jpedal:jpedal:jar:1.0: Could not find artifact javax.jms:jms:jar:1.1 in central (https://repo.maven.apache.org/maven2), try downloading from http://java.sun.com/products/jms/docs.html

Also there were some warnings when downloading POMs:

[INFO] Downloading from central: https://repo.maven.apache.org/maven2/com/lowagie/itext/2.1.7.js5/itext-2.1.7.js5.pom
[WARNING] The POM for com.lowagie:itext:jar:2.1.7.js5 is missing, no dependency information available
[INFO] Downloading from central: https://repo.maven.apache.org/maven2/org/jpedal/jpedal/1.0/jpedal-1.0.pom
[WARNING] The POM for org.jpedal:jpedal:jar:1.0 is missing, no dependency information available

Please help to resolve the errors.
Thank you,
George


#2

Hi @gp1864 ,
from the output, it seems as if you don’t use our maven repository.
We describe how to do that here .

Regards,
Tobias


#3

Hi Tobias,

Indeed I don’t.

Thank you,
George