Failed on setup local development environment!

Hi ,
I tried follow the guides to setup my own eclipse (latest version) , get the codes from gitHub & imported it. but that raised errors during i run " mvn compile " . my maven version is : 3.3.1, jdk
is sun jdk(1.8) , also i could not found such project or package. please see below

Project build error: Non-resolvable parent POM for de.metas:de.metas.parent:1.0.0:
Failure to find de.metas:de.metas.parent.general:pom:1.0.0 in was cached in the local repository,
resolution will not be reattempted until the update interval of central
has elapsed or updates are forced and ‘parent.relativePath’ points at wrong local POM


if you want to run maven from command line (like mvn compile),
then please follow this guide:

Best Regards,

Hi ,
Thanks for kindly share the URL ! but that just few words about set develop environment .
i just confusing where can get this pom.xml ?
[Tiger00:de.metas.parent hulongz$ mvn compile
[INFO] Scanning for projects…


Hi @hulong.z,
I’m sorry for the late reply. I negelected to check our forum for new messages.
Please feel free to @-mention me if you want. That way I should get a Email notification.
Also, fee free to ask such questions at .

About your question:
It seems as if you skipped the part “cd into your working copy of the metasfresh-parent repo and run mvn install”, and therefore the de.metas.parent.general pom.xml is not available in your local cache.

As it is now, in order to build,
you need to also get (should get better when will be done).
Feel free to take a look at to learn about all repos included in a “full” install.
I also recomment to start at, to get an overview.

Best regards